Chapter 21: Specifying Coordinates in 3D
Chapter 22: Viewing 3D Drawings
Chapter 23: Creating 3D Surfaces
Chapter 24: Creating 3D Solids
Chapter 25: Rendering in 3D
Chapter 26: Drawing Control
1) Chapter 21: Specifying Coordinates in 3D (adapted from AutoCAD Bible 2006)
   a) Coordinates are used to define a point in 3D space. Or use Point Filters, Object Snaps, & From (covered earlier) to locate points.
      i) Cartesian Coordinates \((X,Y,Z)\)
      ii) Spherical Coordinates \((D<\text{angle}<\text{angle})\): Distance to point, angle from X axis (in XY plane), angle from XY axis in Z direction
      iii) Cylindrical Coordinates \((D<\text{angle},Z)\): XY Distance, angle from X axis (in XY plane), Z distance
      iv) Reminder: Absolute coordinates (\#) are measured from origin, relative (@) are measured from first point
   b) Wireframes are 3D objects made of wires, i.e., lines. They have no surfaces and are not solid. They aren’t as useful as solids, but they can be used to create solids. Make wire frames with same commands used for 2D drawings.
   c) Create 3D wireframes from 2D objects using Thickness. Position objects at different Z coordinates using Elevation.
      i) Type “elev” at the command line and change the current Elevation & Thickness. All objects subsequently created are positioned at the new Elevation & Thickness.
      ii) Alternatively, change the Elevation &/or Thickness of an existing object using its property table (Select object then <RC> Properties).
   d) Many 2D commands only draw objects parallel to the XY plane. They will accept a Z coordinate for a first point, but not a second. The Z value is the elevation of the object.
      i) Change the UCS to allow the creation of 2D objects in the appropriate orientation. Use Tools→New UCS→…, e.g., to rotate the XY Plane to a desired orientation.
         a) Go back to the World (original) UCS using the World option.
      ii) The Line command is an exception; you can enter different Z values for start and end points. There is a 3D version of the Polyline, 3D Polyline, but it can only be used to draw lines.
   e) Some commands keep the UCS the same. Others change it to align with a new view.
      (1) Use (View→Orbit→…) to use the cursor to freely rotate the object.
      (2) To get to a plan view without changing the UCS use View→3D Views→Plan View→Current UCS.
      (3) To get to a plan view using the World (original) UCS use View→3D Views→Plan View→World UCS.
   f) The DUCS button toggles between dynamic and static UCS. When on, in 3D views, the UCS origin will change and the XY plane will align with solid objects as identified by the cursor location.
   g) Use View→Hide to hide lines that normally would not be seen. However, most Wireframe objects have no top or bottom. Circles are an exception. Use View→Regen to show the hidden lines. The Hide command causes regions to be shown as surfaces.
   h) Use View→Visual Styles to view Wireframe objects in realistic or conceptual styles. Use Tools→Palettes→Visual Styles to customize styles. Or <RC> with Orbit running to select various visual styles via the Visual Styles submenu. <RC> with Orbit running also allows you to select “Perspective” to show a perspective view (i.e., with a vanishing point). Return to the normal parallel view by <RC> Parallel.
      i) Use Clipping Planes to hide objects in front or behind a target object.
2) Chapter 22: Viewing 3D Drawings (adapted from AutoCAD Bible 2008)
   a) Use View→3D Views to access some common views (e.g., Front, Top, Right, SE Isometric…).
      Or use the View toolbar.
      i) Use Viewpoint to make a view with the mouse
      ii) Use Viewpoint Presets to make a well-defined custom view
   b) Make and access Named Views in the View Manager (View→Named Views). Also on the View Toolbar.
      i) Select Named Views (and Cameras) in the View Manager.
      ii) Select New to make new views (e.g., based on the current view).
         (1) Add a background image to a new view in the View Manager.
   c) Return to plan view using View→3D view→Plan View.
   d) Camera views are from specific locations and of specific targets.
      i) Make a camera view by selecting Camera from the View Toolbar. Adjust a camera view
         from View→Camera.
   e) Change visual styles at View→Visual Styles or on the Visual Styles panel of the 3D Dashboard.
      i) 2D Wireframe, 3D Hidden, 3D Wireframe, Conceptual, Realistic.
      ii) Create your own in the Visual Styles Manager, accessed from the Visual Styles panel in the 3D Dashboard or the Visual Styles Toolbar.
   g) Rotate your drawing in realtime using View→Orbit→Free Orbit.
   h) Use Draw→Modeling→Setup→View to setup up views in a layout (paper space). This includes the ability to make inclined views.
3) Chapter 23: Creating 3D Surfaces (adapted from AutoCAD Bible 2006)
   a) A **Surface**, or **Mesh**, is created by combining polygons at their edges. A **Surface** is defined by its **Vertices**, i.e., where lines intersect. They can be shaded and will hide back surfaces.
   b) Use **Draw→Modelling→Meshes→3D Faces** to create surfaces from single polygons with 3 or 4 sides (i.e., triangles and rectangles). Combine polygons to make more complex shapes.
   c) Use **3D Mesh** to create a polygon mesh by specifying the number (M & N directions) & positions of vertices. The edge lines are polylines, and can be edited using **Modify→Object→Polyline**. Editing includes smoothing. This command can be used to manually create topographic surfaces from surveying data, but this is generally automated using AutoLISP (i.e., script) routines that use **3D Mesh** command.
   d) To make standard surface shapes (box, wedge, pyramid, cone, sphere, dome, dish & torus) go to the command line & type “3D” <R> followed by the name of the shape. For example, after selecting the **Box** command, you are prompted to supply the position of the lower-left corner, the length, the width, the height & the rotation angle. **Pyramids** can be drawing with 3 or 4 sided bases and pointed or flat tops. **Cones** can also be pointed or flat topped. Change the number of mesh vertices used with the **SURFTAB1** (M direction) & **SURFTAB2** (N direction) system variables. Before applying the surface shape command, type the system variables into the command line and enter a new value. **SURFTAB1** & **SURFTAB2** also work with the **Revolved Mesh, Tabulated Mesh, Ruled Mesh, & Edge Mesh** Commands.
   e) Create more complicated surfaces using the **Revolved Mesh, Tabulated Mesh, Ruled Mesh, & Edge Mesh** Commands. All are accessed from **Draw→Modelling→Meshes→**
      i) Use **Revolved Mesh** to create a surface by revolving a path curve (e.g., open or closed Polyline) around an axis of revolution (e.g., a Line). Identify the path curve, the axis of revolution, a start angle & an included angle (e.g., 360 to do a complete rotation).
      ii) Use **Tabulated Mesh** to create a surface by extruding a path curve along a vector (e.g., Line). Just click on the path curve & the extrusion vector. The surface will be extruded according to the angle and length of the vector.
      iii) Use **Ruled Mesh** to create a surface that extends from one object to another. Just click on the two objects.
      iv) Use **Edge Mesh** to draw a surface that is bounded by & defined by four connected objects (lines, arcs & Polylines). Draw four objects to create a boundary. They must touch. Start the **Edge Mesh** command and select the four objects in any order. In case you are interested, this command creates a Coon’s surface patch mesh.
4) **Chapter 24: Creating 3D Solids** (adapted from AutoCAD Bible 2006)

   a) Display the 3D Dashboard using **Tools→Palettes→Dashboard**. There is also a 3D workspace.

   b) **Solids** are typically used to make the most realistic models. In addition to making standard shapes and revolving & extruding, you can do more with solids than surfaces, e.g., combine, subtract & fillet. You can also get information about their physical properties.

   c) To make standard solid shapes (box, wedge, pyramid, cone, sphere, dome & torus) use **Draw→Modeling→** select the appropriate shape.

   d) To change the quality of solids display go to **Tools→Options→3D Modeling** and change the number of U & V isolines. This is similar to the SURFTAB1 & 2 parameters for surfaces.

   e) Create more complicated **Solids** using the **Extrude, Revolve, Sweep & Loft** Commands. All are accessed from **Draw→Modeling→**

      i) Use **Extrude** to create a solid by extruding a closed 2D object perpendicular to the object (the default) or perpendicular but tapered or along a path (e.g., Line, Circle, Arc, Ellipse, Elliptical arc, Polyline or Spline).

      ii) Use **Revolve** to create a solid by revolving a closed profile (e.g., 2D Polyline, Circle, Ellipse, Closed spline or Region) around an axis of revolution (e.g., a Line). Identify the profile, the axis of revolution, & the angle of revolution.

      iii) Use **Sweep** to create a new solid or surface by sweeping an open or closed planar curve (profile) along an open or closed 2D or 3D path. If the profile is open, Sweep creates a surface. Apparently, **Sweep** is the new and improved extrude.

      iv) Use **Loft** to create a 3D solid or surface by lofting (drawing a solid or surface) through a set of two or more planer cross-section curves. For example, if you had a group of contour lines, you could create a solid with a top face corresponding to the elevations.

     v) Use **PressPull** to remove or pull a shape from another solid.

   f) Edit **Solids** using the **Union, Subtract, Intersect & Interfere** Commands. Find them, and more, at **Modify→3D Operations→**

      i) Use **Union** to add multiple objects together. If they are touching, it creates a single solid. If they do not touch, **Union** acts like the **Group** command. **Union** can also be used on 2D regions.

      ii) Use **Subtract** to subtract one solid from another.

      iii) Use **Intersect** to create a solid from the volume that two solids have in common.

      iv) **Interfere** does the same thing as Intersect, except it keeps the original solids.

   g) A number of commands that can be used to change the edges or faces of solids are found in the **Modify→3D Operations→** submenu, including **Color Faces**.

   h) The **Fillet & Chamfer** commands (Modify menu) work on solids. For Filleting a corner, first click on the edge you want to fillet, then enter the fillet radius <R>, then click the edge again & <R>.

   i) Use the **Render** toolbar to make realistic “photos” of your drawing. Add different kinds of lighting (including the sun) & shadows. Add “materials”, e.g., wood or marble, to objects. Don’t forget, to access toolbars <RC> in any toolbar and select the toolbar you want to see.

   j) Convert 2D wireframes to **Solids** (or **Surfaces**) at **Modify→3D Operations→Convert to Solid** or **Convert to Surface**.
5) **Chapter 25**: Rendering in 3D (adapted from AutoCAD 2006 & 2008)
   a) **Rendering**
      i) Rendering lets you create more realistic pictures of your drawings. Render from the 3D Dashboard or the **Rendering** toolbar. There are three kinds of rendering
         1) **Render** (default)
         2) **Photo Real**
         3) **Photo Raytrace**
      ii) Render Options include:
         1) **Lights** – Ambient, distant, point, and spotlight
            a) Simulate the sun at any date and time, for any geographic location
         2) **Scenes** – save different views and light configurations
         3) **Materials** – add characteristics to object surfaces (e.g., wood grain)
         4) **Background** & fog effects
   b) **Materials** can be attached to drawings or objects. They can make a surface look like wood, plastic, glass, etc. AutoCAD comes with a **Materials Library** of over 300 materials.
      i) Access materials from the **Tools→Palettes→Tool Palette**. Click at the bottom of the tabs along the left side to access more tabs (including the material tabs)
      ii) Edit material from **Tools→Palettes→Materials**.

6) **Chapter 26**: Drawing Control (adapted from AutoCAD 2009)
   a) **Design Center**
   b) **Tool Palettes**
   c) **Setting Standards**
   d) **Sheet Sets**
   e) **Organizing Your Drawings**
   f) **Security**
F buttons
  g) F1 - Help
  h) F2 – Show past Command in expanded Commandline window
  i) F3 – Toggle OSNAP
  j) F4
  k) F5
  l) F6
  m) F7
  n) F8 – Toggle ORTHO
  o) F9 – Toggle SNAP
  p) F10 – Toggle POLAR
  q) F11 – Toggle OTRACK
  r) F12 – Turn off/on Dynamic Input